Keep IvyDE compatible with Ivy 2.1, as stated on the doc.
authorNicolas Lalevée <nicolas.lalevee@hibnet.org>
Sun, 1 Jul 2018 12:27:10 +0000 (14:27 +0200)
committerNicolas Lalevée <nicolas.lalevee@hibnet.org>
Sun, 1 Jul 2018 12:27:10 +0000 (14:27 +0200)
org.apache.ivyde.eclipse.resolvevisualizer.feature/feature.xml
org.apache.ivyde.eclipse.resolvevisualizer/META-INF/MANIFEST.MF
org.apache.ivyde.eclipse/META-INF/MANIFEST.MF
org.apache.ivyde.feature/feature.xml

index 4c78fd4..1abca74 100644 (file)
@@ -49,7 +49,7 @@
       <import plugin="org.eclipse.jdt.core" version="3.9.0" match="compatible"/>
       <import plugin="org.eclipse.core.resources" version="3.8.0" match="compatible"/>
       <import plugin="org.eclipse.ui.forms" version="3.6.0" match="compatible"/>
-      <import plugin="org.apache.ivy" version="2.5.0" match="compatible"/>
+      <import plugin="org.apache.ivy" version="2.1.0" match="compatible"/>
    </requires>
 
    <plugin
index f87fc00..1ff258a 100644 (file)
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.ui;bundle-version="[3.105.0,4.0.0)",
  org.apache.ivyde.eclipse;bundle-version="[2.3.0,2.4.0)",
  org.eclipse.zest.core;bundle-version="[1.5.0,2.0.0)",
  org.eclipse.zest.layouts;bundle-version="[1.1.0,2.0.0)",
- org.apache.ivy;bundle-version="[2.5.0,3.0.0)",
+ org.apache.ivy;bundle-version="[2.1.0,3.0.0)",
  org.eclipse.jdt.core;bundle-version="[3.9.0,4.0.0)",
  org.eclipse.core.resources;bundle-version="[3.8.0,4.0.0)",
  org.eclipse.ui.forms;bundle-version="[3.6.0,4.0.0)"
index b3cd307..66c1280 100644 (file)
@@ -27,7 +27,7 @@ Require-Bundle: org.apache.xerces;bundle-version="[2.9.0,3.0.0)";resolution:=opt
  org.eclipse.jdt.core;bundle-version="[3.9.0,4.0.0)",
  org.eclipse.jdt.ui;bundle-version="[3.9.0,4.0.0)",
  org.eclipse.ui.console;bundle-version="[3.5.0,4.0.0)",
- org.apache.ivy;bundle-version="[2.5.0,3.0.0)",
+ org.apache.ivy;bundle-version="[2.1.0,3.0.0)",
  org.eclipse.help;bundle-version="[3.6.0,4.0.0)",
  org.eclipse.wst.xml.core;bundle-version="[1.1.0,2.0.0)";resolution:=optional,
  org.eclipse.debug.core;bundle-version="[3.8.0,4.0.0)",
index 28aa987..9762ddf 100644 (file)
@@ -54,7 +54,7 @@
       <import plugin="org.eclipse.jdt.core" version="3.9.0" match="compatible"/>
       <import plugin="org.eclipse.jdt.ui" version="3.9.0" match="compatible"/>
       <import plugin="org.eclipse.ui.console" version="3.5.0" match="compatible"/>
-      <import plugin="org.apache.ivy" version="2.5.0" match="compatible"/>
+      <import plugin="org.apache.ivy" version="2.1.0" match="compatible"/>
       <import plugin="org.eclipse.help" version="3.6.0" match="compatible"/>
       <import plugin="org.eclipse.debug.core" version="3.8.0" match="compatible"/>
       <import plugin="org.eclipse.jdt.launching" version="3.7.0" match="compatible"/>