fix: vulnerabilities of third-party dependent libraries: CVE-2019-19794 CVE-2020...
[apisix-go-plugin-runner.git] / Makefile
index 465326eb6b7f3256dc3abfecf0a0b3ee5bc493f0..321ac00770a719880864a71b17bfdd468737ae81 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -17,9 +17,9 @@
 default: help
 
 VERSION ?= latest
-RELEASE_SRC = apache-apisix-go-plugin-runner-${VERSION}-src
+RELEASE_SRC = apisix-go-plugin-runner-${VERSION}-src
 
-GITSHA ?= $(shell git rev-parse --short=7 HEAD)
+GITSHA ?= $(shell git rev-parse --short=7 HEAD 2> /dev/null || echo '')
 OSNAME ?= $(shell uname -s | tr A-Z a-z)
 OSARCH ?= $(shell uname -m | tr A-Z a-z)
 PWD ?= $(shell pwd)
@@ -64,6 +64,7 @@ compress-tar:
        ./pkg \
        LICENSE \
        Makefile \
+       NOTICE \
        go.mod \
        go.sum \
        *.md