Update to Django 4 and minimum python 3.8 main
authorGary Martin <gjm@apache.org>
Mon, 14 Mar 2022 13:28:23 +0000 (13:28 +0000)
committerGary Martin <gjm@apache.org>
Mon, 14 Mar 2022 13:31:08 +0000 (13:31 +0000)
README.md
pyproject.toml

index eef74ec7c8d7ef54816278538bd0a2db3c60ce42..c093bbf74f56d15cd5ffdf3eaa55ff2fd55f2302 100644 (file)
--- a/README.md
+++ b/README.md
@@ -27,7 +27,7 @@ This version of Apache Bloodhound requires Python, Poetry and Django.
 
 ### Installing Python
 
 
 ### Installing Python
 
-The versions of Python that can be used are currently 3.6, 3.7, 3.8 and 3.9.
+The versions of Python that can be used are currently 3.8, 3.9 and 3.10.
 
 Where convenient is it sensible to go for the newest release of Python that
 you can.
 
 Where convenient is it sensible to go for the newest release of Python that
 you can.
index 025e0d5bd981c3e18462e05036bda0fde2442df2..94367d4884728706df8a44eabe0fc9f739a5385d 100644 (file)
@@ -6,12 +6,13 @@ authors = ["Apache Bloodhound <dev@bloodhound.apache.org>"]
 license = "Apache-2.0"
 
 [tool.poetry.dependencies]
 license = "Apache-2.0"
 
 [tool.poetry.dependencies]
-python = "^3.6"
-django = "^3.2.2"
-django-rest-framework = "^0.1.0"
+python = "^3.8"
+Django = "^4.0.3"
+djangorestframework = "^3.13.1"
+Markdown = "^3.3.6"
 drf-yasg = "^1.20.0"
 drf-yasg = "^1.20.0"
-drf-nested-routers = "^0.93.3"
-pyyaml = "^5.4.1"
+drf-nested-routers = "^0.93.4"
+PyYAML = "^6.0"
 psycopg2 = { version = "^2.9", optional = true }
 psycopg2-binary = { version = "^2.9", optional = true }
 
 psycopg2 = { version = "^2.9", optional = true }
 psycopg2-binary = { version = "^2.9", optional = true }