Update to Django 4 and minimum python 3.8