updating to latest ruby - 3.0.1 - ruby installs but doesn't yet run