Bump commons.pmd-impl.version from 6.46.0 to 6.47.0