Set VERSION to 3.4.0-dev