Update dependencies
authorDarryl Pogue <darryl@dpogue.ca>
Fri, 4 May 2018 06:11:32 +0000 (23:11 -0700)
committerDarryl Pogue <dvpdiner2@gmail.com>
Fri, 18 May 2018 16:56:19 +0000 (09:56 -0700)
package.json
src/superspawn.js

index 7e0b096..609e8ff 100644 (file)
@@ -14,7 +14,7 @@
   },
   "main": "cordova-common.js",
   "engines": {
-    "node": ">=4.0.0"
+    "node": ">=6.0.0"
   },
   "scripts": {
     "test": "npm run eslint && npm run jasmine",
     "ansi": "^0.3.1",
     "bplist-parser": "^0.1.0",
     "cordova-registry-mapper": "^1.1.8",
-    "elementtree": "0.1.6",
-    "glob": "^5.0.13",
+    "elementtree": "0.1.7",
+    "glob": "^7.1.2",
     "minimatch": "^3.0.0",
-    "osenv": "^0.1.3",
-    "plist": "^1.2.0",
+    "plist": "^3.0.1",
     "q": "^1.4.1",
-    "semver": "^5.0.1",
-    "shelljs": "^0.5.3",
-    "underscore": "^1.8.3",
-    "unorm": "^1.3.3"
+    "shelljs": "^0.8.1",
+    "underscore": "^1.8.3"
   },
   "devDependencies": {
     "eslint": "^4.0.0",
-    "eslint-config-semistandard": "^11.0.0",
-    "eslint-config-standard": "^10.2.1",
+    "eslint-config-semistandard": "^12.0.1",
+    "eslint-config-standard": "^11.0.0",
     "eslint-plugin-import": "^2.3.0",
-    "eslint-plugin-node": "^5.0.0",
+    "eslint-plugin-node": "^6.0.1",
     "eslint-plugin-promise": "^3.5.0",
     "eslint-plugin-standard": "^3.0.1",
     "istanbul": "^0.4.5",
-    "jasmine": "^2.5.2",
+    "jasmine": "^3.1.0",
+    "osenv": "^0.1.3",
     "promise-matchers": "^0.9.6",
-    "rewire": "^2.5.1"
+    "rewire": "^4.0.1"
   },
   "contributors": []
 }
index 424934e..8051184 100644 (file)
@@ -35,7 +35,7 @@ function resolveWindowsExe (cmd) {
     if (isValidExe(cmd)) {
         return cmd;
     }
-    cmd = shell.which(cmd) || cmd;
+    cmd = String(shell.which(cmd) || cmd);
     if (!isValidExe(cmd)) {
         winExtensions.some(function (ext) {
             if (fs.existsSync(cmd + ext)) {