CB-13294 Remove cordova-plugin-compat
authorKelvin Dart <kelvin.dart@crimsontide.co.uk>
Wed, 18 Oct 2017 15:42:36 +0000 (16:42 +0100)
committerSteve Gill <stevengill97@gmail.com>
Fri, 20 Oct 2017 01:51:19 +0000 (18:51 -0700)
 This closes #156

package.json
plugin.xml

index ad126a3..9c44bfe 100644 (file)
@@ -1,6 +1,6 @@
 {
   "name": "cordova-plugin-contacts",
-  "version": "2.3.2-dev",
+  "version": "3.0.0-dev",
   "description": "Cordova Contacts Plugin",
   "types": "./types/index.d.ts",
   "cordova": {
@@ -48,7 +48,7 @@
   "engines": {
     "cordovaDependencies": {
       "3.0.0": {
-        "cordova": ">100"
+        "cordova-android": ">=6.3.0"
       }
     }
   },
index 380a06e..039a706 100644 (file)
@@ -24,7 +24,7 @@
     xmlns:m3="http://schemas.microsoft.com/appx/2014/manifest"
     xmlns:uap="http://schemas.microsoft.com/appx/manifest/uap/windows10"
     id="cordova-plugin-contacts"
-    version="2.3.2-dev">
+    version="3.0.0-dev">
 
     <name>Contacts</name>
     <description>Cordova Contacts Plugin</description>
@@ -33,7 +33,9 @@
     <repo>https://git-wip-us.apache.org/repos/asf/cordova-plugin-contacts.git</repo>
     <issue>https://issues.apache.org/jira/browse/CB/component/12320652</issue>
 
-    <dependency id="cordova-plugin-compat" version="^1.0.0" />
+    <engines>
+        <engine name="cordova-android" version=">=6.3.0" />
+    </engines>
 
     <js-module src="www/contacts.js" name="contacts">
         <clobbers target="navigator.contacts" />