Adding jsr311 specs dependency, update cxf.version to 2.3-SNAPSHOT (can be downgraded...
authorSergey Beryozkin <sergeyb@apache.org>
Wed, 10 Jun 2009 11:27:00 +0000 (11:27 +0000)
committerSergey Beryozkin <sergeyb@apache.org>
Wed, 10 Jun 2009 11:27:00 +0000 (11:27 +0000)
git-svn-id: https://svn.apache.org/repos/asf/cxf/dosgi/trunk@783297 13f79535-47bb-0310-9956-ffa450edef68

distribution/multi-bundle/pom.xml
distribution/multi-bundle/src/main/resources/distro_bundles.xml
distribution/single-bundle/pom.xml
parent/pom.xml

index 62320ff..c792ef0 100644 (file)
       <version>${servicemix.specs.version}</version>
     </dependency>
     <dependency>
+      <groupId>org.apache.servicemix.specs</groupId>
+      <artifactId>org.apache.servicemix.specs.jsr311-api-1.0</artifactId>
+      <version>${servicemix.specs.version}</version>
+    </dependency>
+    <dependency>
       <groupId>org.apache.servicemix.bundles</groupId> 
       <artifactId>org.apache.servicemix.bundles.xmlschema</artifactId> 
       <version>${xmlschema.bundle.version}</version> 
index 7f1bb18..509cd3e 100644 (file)
@@ -28,6 +28,9 @@
   <bundle>cxf-dosgi-ri-multibundle-distribution-${project.version}.dir/apache-cxf-dosgi-ri-${project.version}/dosgi_bundles/org.apache.servicemix.specs.stax-api-1.0-${servicemix.specs.version}.jar</bundle>
   <bundle>cxf-dosgi-ri-multibundle-distribution-${project.version}.dir/apache-cxf-dosgi-ri-${project.version}/dosgi_bundles/org.apache.servicemix.specs.jaxb-api-2.1-${servicemix.specs.version}.jar</bundle>
   <bundle>cxf-dosgi-ri-multibundle-distribution-${project.version}.dir/apache-cxf-dosgi-ri-${project.version}/dosgi_bundles/org.apache.servicemix.specs.jaxws-api-2.1-${servicemix.specs.version}.jar</bundle>
-  <bundle>cxf-dosgi-ri-multibundle-distribution-${project.version}.dir/apache-cxf-dosgi-ri-${project.version}/dosgi_bundles/cxf-dosgi-ri-discovery-local-${pom.version}.jar</bundle>
+<bundle>cxf-dosgi-ri-multibundle-distribution-${project.version}.dir/apache-cxf-dosgi-ri-${project.version}/dosgi_bundles/org.apache.servicemix.specs.jsr311-api-1.0-${servicemix.specs.version}.jar</bundle>
+
+<bundle>cxf-dosgi-ri-multibundle-distribution-${project.version}.dir/apache-cxf-dosgi-ri-${project.version}/dosgi_bundles/cxf-dosgi-ri-discovery-local-${pom.version}.jar</bundle>
   <bundle>cxf-dosgi-ri-multibundle-distribution-${project.version}.dir/apache-cxf-dosgi-ri-${project.version}/dosgi_bundles/cxf-dosgi-ri-dsw-cxf-${pom.version}.jar</bundle>
 </bundles>
index cd30c33..941889b 100644 (file)
       <version>${servicemix.specs.version}</version>
     </dependency>
     <dependency>
+      <groupId>org.apache.servicemix.specs</groupId>
+      <artifactId>org.apache.servicemix.specs.jsr311-api-1.0</artifactId>
+      <version>${servicemix.specs.version}</version>
+    </dependency>
+    <dependency>
       <groupId>org.apache.servicemix.bundles</groupId> 
       <artifactId>org.apache.servicemix.bundles.xmlschema</artifactId> 
       <version>${xmlschema.bundle.version}</version> 
index 4f425e6..961c822 100644 (file)
          generally caused by the fact that not all versions are available yet as 
          OSGi bundles. -->
     <properties>
-        <cxf.version>2.2.1</cxf.version>
+        <cxf.version>2.2.3-SNAPSHOT</cxf.version>
         <felix.version>1.8.0</felix.version>
         <spring.version>2.5.6</spring.version>
         <spring.osgi.version>1.2.0</spring.osgi.version>
         <zookeeper.version>3.0.0</zookeeper.version>
 
-        <servicemix.specs.version>1.1.1</servicemix.specs.version>
+        <servicemix.specs.version>1.3.0</servicemix.specs.version>
 
         <log4j.version>1.2.15</log4j.version>
         <jetty.version>6.1.16</jetty.version>