Updating pmd plugin to 3.16.0 to remove some WARNINGs