update plexus-utils to 3.4.2