feature: package with dependence lib