update read me so it clearer which swcs are required