[poc] Fix repository and add compatibility
[flink-connectors.git] / build.gradle.kts
index 044fd5b174935b35f46a78f837cf88a54d59f215..c390270a32d2746abc9a43b6530d1cdb91319d39 100644 (file)
@@ -5,6 +5,23 @@ plugins {
     checkstyle
 }
 
+group = "org.apache.flink.connectors"
+version = "1.0.0-SNAPSHOT"
+
+allprojects {
+    apply(plugin = "java-library")
+
+    java {
+        toolchain {
+            languageVersion.set(JavaLanguageVersion.of(8))
+        }
+    }
+
+    repositories {
+        mavenCentral()
+    }
+}
+
 val isCiServer = System.getenv().containsKey("CI")
 //if (!gradle.startParameter.isOffline && isCiServer) {
     configure<com.gradle.scan.plugin.BuildScanExtension> {
@@ -13,13 +30,6 @@ val isCiServer = System.getenv().containsKey("CI")
     }
 //}
 
-group = "org.apache.flink.connectors"
-version = "1.0.0-SNAPSHOT"
-
-repositories {
-    mavenCentral()
-}
-
 configure<com.diffplug.gradle.spotless.SpotlessExtension> {
     java {
         googleJavaFormat("1.7").aosp()
@@ -30,14 +40,6 @@ configure<CheckstyleExtension> {
 }
 
 subprojects {
-    apply(plugin = "java-library")
-
-    java {
-        toolchain {
-            languageVersion.set(JavaLanguageVersion.of(8))
-        }
-    }
-
     dependencies {
         testImplementation("org.junit.jupiter:junit-jupiter-api:5.6.0")
         testRuntimeOnly("org.junit.jupiter:junit-jupiter-engine")