[poc] Fix repository and add compatibility