Build PyFlink image with compatible Python version (#28)