FLUME-2935. Bump java target version to 1.7
authorMike Percy <mpercy@cloudera.com>
Sun, 26 Jun 2016 21:17:37 +0000 (14:17 -0700)
committerMike Percy <mpercy@cloudera.com>
Sun, 26 Jun 2016 21:17:37 +0000 (14:17 -0700)
commit2f731f0aaeb490ab72400d8c83074daac840ac44
treef21c51af464b76b05d409270974803d2892395d6
parent4a7db4a363a7ed7391e11685bb6a0f47cbfa2328
FLUME-2935. Bump java target version to 1.7

* Renamed README to README.textile in order to allow GitHub to properly
  render the headings. Also changed the min. requirement to JDK 1.7
* pom.xml:
  * Changed the sourceJavaVersion and targetJavaVersion to 1.7
  * Removed the test dependency hadoop-minicluster since it is already
    required as a "normal" dependency. This was causing Maven warnings
* flume-ng-elasticsearch-sink/pom.xml: pom file had two identical
  dependencies, causing Maven warnings
* FlumeUserGuide.rst: changed the system requirements to Java 1.7
* KafkaLocal.java: The tests threw a MethodNotFoundException, since
  there isn't a constructor for KafkaConfig with a java.util.properties
  parameter. Instead, I used the static method KafkaConfig.fromProps.

(Lior Zeno via Mike Percy)
README [deleted file]
README.textile [new file with mode: 0644]
flume-ng-doc/sphinx/FlumeUserGuide.rst
flume-ng-sinks/flume-ng-elasticsearch-sink/pom.xml
flume-ng-sinks/flume-ng-kafka-sink/src/test/java/org/apache/flume/sink/kafka/util/KafkaLocal.java
pom.xml