GUACAMOLE-526: Merge changes correcting regression in CAS due to AngularJS update. 1.0.0 1.0.0-RC1
authorMichael Jumper <mjumper@apache.org>
Wed, 5 Dec 2018 22:32:37 +0000 (14:32 -0800)
committerMichael Jumper <mjumper@apache.org>
Wed, 5 Dec 2018 22:32:37 +0000 (14:32 -0800)
Including `ngRoute` as a dependency of a module which defines a custom
field type will always result in the following error:

    Unknown provider: $rootElementProvider <- $rootElement <- $location <- $route <- $location

This seems to be due to the manner in which the injector is created for
field types. `$rootElementProvider` is not available for injection in
the context of the injector of a custom field. This is generally OK, but
`ngRoute` transitively depends on `$rootElementProvider`. Since
`$rootElementProvider` cannot be injected within the context of a field
type, no field type can depend on ngRoute without causing this error.

Note that extensions can still leverage `ngRoute` (this is already done
by the OpenID support). It just cannot be declared as a dependency of a
module containing a custom field type.


Trivial merge