HBASE-27148 Move minimum hadoop 3 support version to 3.2.3 (#4561)