HIVE-26205: Incorrect scope for slf4j-api dependency in kafka-handler (Wechar Yu...
authorwecharyu <weiqiang.yu@shopee.com>
Sat, 7 May 2022 12:56:54 +0000 (20:56 +0800)
committerStamatis Zampetakis <zabetak@gmail.com>
Mon, 16 May 2022 14:46:36 +0000 (16:46 +0200)
commit74e3f29b4328b5df5a1cd90de12ec3e35301afae
treef5d6200de899f18e72cd6d412b639645d15d9044
parent3b3da9ed7f3813bae3e959670df55682fea648d3
HIVE-26205: Incorrect scope for slf4j-api dependency in kafka-handler (Wechar Yu, reviewed by Stamatis Zampetakis)

The classes in the kafka-handler module are using the slf4j-api thus
this dependency must be set at compile scope. Currently it is set at
test scope which makes the build fail in some recent maven versions (
e.g., 3.8.5).

The parent pom declares explicitly slf4j-api at compile scope so
removing all the references from kafka-handler/pom.xml is the way to
go.

Closes #3272
kafka-handler/pom.xml