[UPGRADE] Spark 2.9.3 -> 2.9.4 (#1129)