jclouds.git
3 months agoApache jclouds 2.5.0-rc1 release rel/jclouds-2.5.0 rel/jclouds-2.5.0-rc1
Andrew Gaul [Sun, 20 Mar 2022 13:18:41 +0000 (22:18 +0900)] 
Apache jclouds 2.5.0-rc1 release

3 months agoJCLOUDS-1599 - Add support for GLACIER_IR storage class
ramahin [Tue, 8 Mar 2022 20:47:20 +0000 (13:47 -0700)] 
JCLOUDS-1599 - Add support for GLACIER_IR storage class

4 months agoJCLOUDS-1598: Support Metric Alert Operation (#134)
SATYANAN-ANAND [Fri, 25 Feb 2022 18:12:43 +0000 (10:12 -0800)] 
JCLOUDS-1598: Support Metric Alert Operation (#134)

4 months agoJCLOUDS-1597: Support for Alerts (#133)
SATYANAN-ANAND [Mon, 21 Feb 2022 10:37:50 +0000 (02:37 -0800)] 
JCLOUDS-1597: Support for Alerts (#133)

4 months agoUpdate AzureComputeApi.java
SATYANAN-ANAND [Tue, 1 Feb 2022 14:26:48 +0000 (06:26 -0800)] 
Update AzureComputeApi.java

4 months agoJCLOUDS-1596: Support Activity Log Alert Operations
SATYANAN-ANAND [Tue, 1 Feb 2022 11:29:47 +0000 (03:29 -0800)] 
JCLOUDS-1596: Support Activity Log Alert Operations

5 months agoJCLOUDS-1594: Allow overriding S3 signer
Andrew Gaul [Fri, 31 Dec 2021 10:53:04 +0000 (19:53 +0900)] 
JCLOUDS-1594: Allow overriding S3 signer

Previously s3 always used v2 and aws-s3 always used v4.  Now s3
defaults to v2 and can override to v4.  Note that this does not change
BlobRequestSigner.

6 months agoJCLOUDS-1591: Fix NPE in ClientCredentialsClaims
SATYANAN-ANAND [Mon, 27 Dec 2021 07:26:28 +0000 (12:56 +0530)] 
JCLOUDS-1591: Fix NPE in ClientCredentialsClaims

6 months agoJCLOUDS-1589: Upgrade to log4j 2.17.0
Andrew Gaul [Sun, 19 Dec 2021 00:29:44 +0000 (09:29 +0900)] 
JCLOUDS-1589: Upgrade to log4j 2.17.0

This addresses a high severity CVE:

https://logging.apache.org/log4j/2.x/security.html

6 months agoJCLOUDS-1590: Promote glacier to core 127/head
Andrew Gaul [Fri, 17 Dec 2021 05:00:12 +0000 (14:00 +0900)] 
JCLOUDS-1590: Promote glacier to core

6 months agoMerge remote-tracking branch 'jclouds-labs-aws-local/promote-glacier-moved' into...
Andrew Gaul [Fri, 17 Dec 2021 04:55:10 +0000 (13:55 +0900)] 
Merge remote-tracking branch 'jclouds-labs-aws-local/promote-glacier-moved' into promoted-glacier

6 months agoJCLOUDS-1589: Upgrade to log4j 2.16.0
Andrew Gaul [Fri, 17 Dec 2021 04:33:38 +0000 (13:33 +0900)] 
JCLOUDS-1589: Upgrade to log4j 2.16.0

This addresses a critical CVE:

https://logging.apache.org/log4j/2.x/security.html

6 months agoJCLOUDS-1589: Upgrade to log4j 2.16.0
Andrew Gaul [Thu, 16 Dec 2021 13:47:46 +0000 (22:47 +0900)] 
JCLOUDS-1589: Upgrade to log4j 2.16.0

This addresses a critical CVE:

https://logging.apache.org/log4j/2.x/security.html

7 months agoJCLOUDS-1588: Bump google gson to 2.8.9 due to detected vulnerability (#124)
Juan Cabrerizo [Wed, 10 Nov 2021 10:51:52 +0000 (10:51 +0000)] 
JCLOUDS-1588: Bump google gson to 2.8.9 due to detected vulnerability (#124)

7 months agoJCLOUDS-1586: Upgrade to Guice 5.0.1
Andrew Gaul [Sun, 31 Oct 2021 09:01:40 +0000 (18:01 +0900)] 
JCLOUDS-1586: Upgrade to Guice 5.0.1

Guice 4.2.3 makes illegal reflective accesses that Java 17 does not
allow.  References google/guice#1133.  Release notes:

https://github.com/google/guice/wiki/Guice501

8 months agoRemoved unused jetty-server dependency
Andrew Gaul [Sat, 18 Sep 2021 21:48:18 +0000 (06:48 +0900)] 
Removed unused jetty-server dependency

9 months agoNext development version 2.5.0-SNAPSHOT
Andrew Gaul [Sat, 18 Sep 2021 23:59:59 +0000 (08:59 +0900)] 
Next development version 2.5.0-SNAPSHOT

9 months agoNext development version 2.4.0-SNAPSHOT
Andrew Gaul [Sat, 18 Sep 2021 23:58:25 +0000 (08:58 +0900)] 
Next development version 2.4.0-SNAPSHOT

9 months agoJCLOUDS-1584 : Deployment API fails when ARM Template deploys for creating Azure VM
Rajani-cloud [Mon, 30 Aug 2021 10:43:22 +0000 (06:43 -0400)] 
JCLOUDS-1584 : Deployment API fails when ARM Template deploys for creating Azure VM

10 months agoJCLOUDS-1558: Implement Azure Blob Azure AD auth 120/head
Timur Alperovich [Tue, 10 Aug 2021 06:46:24 +0000 (23:46 -0700)] 
JCLOUDS-1558: Implement Azure Blob Azure AD auth

Implements the Azure AD authentication for Azure Blob, using the OAuth
module. Added more parameters to the AzureBlob provider:
- azureblob.auth
- azureblob.account
- azureblob.tenantId

The "auth" parameter is used to specify whether Key/SAS auth or Active
Directory is used. When using Active Directory auth, the identity no
longer maps to the storage account, which has to be specified
explicitly. The tenant ID also needs to be supplied to construct the
auth URL to obtain the token correctly.

10 months agoAzureBlob: Update API to 2017-11-09
Timur Alperovich [Mon, 16 Aug 2021 06:50:47 +0000 (23:50 -0700)] 
AzureBlob: Update API to 2017-11-09

10 months agoStore the MPU ETag for the transient blobstore
Timur Alperovich [Wed, 4 Aug 2021 08:33:57 +0000 (01:33 -0700)] 
Store the MPU ETag for the transient blobstore

JCLOUDS-1582: fixes a bug in the transient blobstore where after
uploading a multipart upload, GET/HEAD returns the hash of the content,
rather than the MPU ETag.

11 months agoPrefer case-insenstive header comparisons
Andrew Gaul [Tue, 27 Jul 2021 23:42:22 +0000 (08:42 +0900)] 
Prefer case-insenstive header comparisons

Follows up to #116.

11 months agoFix location header case sensitive
Simone Locci [Mon, 26 Jul 2021 14:03:50 +0000 (16:03 +0200)] 
Fix location header case sensitive

11 months agoAdd missing javax dependencies for modern Java
Andrew Gaul [Sat, 10 Jul 2021 02:20:20 +0000 (11:20 +0900)] 
Add missing javax dependencies for modern Java

Java 9 modularization removed these.

11 months agoRemove tests which rely on an isolated ClassLoader
Andrew Gaul [Sat, 10 Jul 2021 02:47:03 +0000 (11:47 +0900)] 
Remove tests which rely on an isolated ClassLoader

Java 9 returns jdk.internal.loader.ClassLoaders$AppClassLoader instead
of URLClassLoader so we cannot create an isolated ClassLoader.

11 months agoRemove Google appengine driver
Andrew Gaul [Thu, 15 Jul 2021 01:21:19 +0000 (10:21 +0900)] 
Remove Google appengine driver

This has an incompatibility with JAXB motivating this removal.
jclouds GAE has not seen any development or issues in recent years and
uses a very old appengine-api-1.0-sdk dependency.  Further it appears
to have modern Guava incompatibilities as seen in JCLOUDS-836.

11 months agoUpgrade to duplicate-finder-maven-plugin 1.5.0
Andrew Gaul [Thu, 15 Jul 2021 01:04:23 +0000 (10:04 +0900)] 
Upgrade to duplicate-finder-maven-plugin 1.5.0

Notably this fixes an issue with duplicate module-version files in
JAXB.  Release notes:

https://github.com/basepom/duplicate-finder-maven-plugin/releases

11 months agoUpgrade animal sniffer to 1.20
Andrew Gaul [Sat, 10 Jul 2021 04:00:04 +0000 (13:00 +0900)] 
Upgrade animal sniffer to 1.20

This addresses a bad class file issues seen when using an explicit
JAXB dependency.  Release notes:

https://github.com/mojohaus/animal-sniffer/releases

11 months agoIgnore copyOf method when testing with modern Java
Andrew Gaul [Sat, 10 Jul 2021 02:27:38 +0000 (11:27 +0900)] 
Ignore copyOf method when testing with modern Java

11 months agoUpgrade to EasyMock 4.3
Andrew Gaul [Sat, 10 Jul 2021 02:47:23 +0000 (11:47 +0900)] 
Upgrade to EasyMock 4.3

This upgrades asm which improves compatibility with modern Java.
Release notes:

https://github.com/easymock/easymock/releases

11 months agoJCLOUDS-1516: specify host name when creating bucket
didixith [Sat, 10 Jul 2021 02:35:16 +0000 (08:05 +0530)] 
JCLOUDS-1516: specify host name when creating bucket

12 months agoJCLOUDS-1581: Make CORS maxAgeSeconds optional
Andrew Gaul [Tue, 29 Jun 2021 23:09:06 +0000 (08:09 +0900)] 
JCLOUDS-1581: Make CORS maxAgeSeconds optional

This field is not required:

https://cloud.google.com/storage/docs/cross-origin#cors-elements

12 months agoJCLOUDS-1577 - Allow to provide Azure Plan Information when starting custom image...
Miroslav Novak [Fri, 7 May 2021 13:20:19 +0000 (15:20 +0200)] 
JCLOUDS-1577 - Allow to provide Azure Plan Information when starting custom image based on Azure Marketplace image.

12 months agoRe-optimize LocalBlobStore.getBlob with ranges
Andrew Gaul [Thu, 24 Jun 2021 11:57:30 +0000 (20:57 +0900)] 
Re-optimize LocalBlobStore.getBlob with ranges

This fixes a memory regression from
8de7b696e13f7131b3ea4a77b10f5cfd139dd712 where the transient BlobStore
changed from a ByteSource to a byte[].

12 months agoJCLOUDS-1580 - Add support for lowercase metadata headers
i831992 [Wed, 23 Jun 2021 00:28:29 +0000 (14:28 -1000)] 
JCLOUDS-1580 - Add support for lowercase metadata headers

The issue happens if a cloud provider returns lowercase metadata headers, for example: "x-object-meta-apiversion" instead of "X-Object-Meta-ApiVersion"

In that case, BlobStore.blobMetadata(CONTAINER, PATH).getUserMetadata()
incorrectly returns an empty map.

This happens because the code is looking for the exact String "-Meta-" (case-sensitive).

This checkin allows to handle metadata headers of any case, and also adds a unit test for that situation.

14 months agoRemove error-prone
Andrew Gaul [Wed, 14 Apr 2021 14:25:41 +0000 (23:25 +0900)] 
Remove error-prone

This does strange things with the java compiler which makes it
incompatible with more modern Java versions.

14 months agoNext development version 2.4.0-SNAPSHOT
Andrew Gaul [Wed, 14 Apr 2021 14:14:10 +0000 (23:14 +0900)] 
Next development version 2.4.0-SNAPSHOT

14 months agoNext development version 2.4.0-SNAPSHOT
Andrew Gaul [Wed, 14 Apr 2021 14:04:13 +0000 (23:04 +0900)] 
Next development version 2.4.0-SNAPSHOT

15 months agoParse out of order ListBuckets response elements
Timur Alperovich [Sun, 4 Apr 2021 01:06:41 +0000 (18:06 -0700)] 
Parse out of order ListBuckets response elements

Currently, jclouds assumes that the ListBuckets response follows a
specific order: the <Owner> tag, followed by the <Buckets> tag. Within
the <Owner> tag, jclouds further assumes that the <ID> must occur before
the <DisplayName> tag. If the XML body does not adhere to this order,
the parser throws a NullPointerException.

DigitalOcean spaces does not adhere to this order and returns the
<DisplayName> tag before the <ID> tag. The patch changes the parser to
not depend on the order of the tags.

15 months agoJCLOUDS-1572: Update GCS bucket regions
Andrew Gaul [Wed, 31 Mar 2021 02:51:08 +0000 (11:51 +0900)] 
JCLOUDS-1572: Update GCS bucket regions

16 months agoS3 APIs: Remove the dependency to com.jamesmurty.utils:java-xmlbuilder (#98)
Jean-Noël Rouvignac [Mon, 1 Mar 2021 14:01:10 +0000 (15:01 +0100)] 
S3 APIs: Remove the dependency to com.jamesmurty.utils:java-xmlbuilder (#98)

XMLBuilder is a very nice fluent API for building XML documents.
However, it is only used by a tiny portion of jclouds: the s3 api. The
use of the XMLBuilder class requires a dependency to
com.jamesmurty.utils:java-xmlbuilder jar and a transitive
dependency to the net.iharder:base64 jar (superseded by
java.util.Base64 in java 8). They are 18kb each approximately and they
not OSGi compatible. They are not huge, but they represent more API
surface and more things to change when trying to use jclouds in an OSGi
context (they need to be replaced by OSGi compatible bundles like
org.apache.servicemix.bundles.java-xmlbuilder).

This commit replaces the use of XMLBuilder by a direct use of the
javax.xml and org.w3c.dom APIs.

I hope retesting will be minimal, and most of this code is covered by
unit tests.

16 months agoAvoid using the guice injector int ests which triggers an NPE
Jean-Noël Rouvignac [Mon, 1 Mar 2021 10:49:24 +0000 (11:49 +0100)] 
Avoid using the guice injector int ests which triggers an NPE

16 months agoRemove maven emma plugin 2.3.x
gurkerl83 [Mon, 14 Dec 2020 11:16:27 +0000 (12:16 +0100)] 
Remove maven emma plugin

Previously, the plugin "emma" was integrated/used for maven site deployment. The following commits removed site deployment entirely.
For reference
- https://github.com/apache/jclouds/pull/91/commits/e02503e1cb59a19e7c48099ce1767ef5f3b7e816
- https://github.com/apache/jclouds/pull/91/commits/9158ab0b0eb7f0a9a9f889cfc86f7bcef7868ff3

16 months agoRestructure build profiles
gurkerl83 [Mon, 14 Dec 2020 10:17:46 +0000 (11:17 +0100)] 
Restructure build profiles

The project requires at least JDK version 8. The specification to disable the liniting process in the JavaDoc process as of JDK version 8 is thus doubly specified and fulfilled by default; an explicit specification is no longer required. Version 3 of the JavaDoc plugin removes the "additional param" configuration attribute. The "doclint=false" configuration attribute disables the lint operation of the plugin.

Summary:
- Remove the profile "disable-doclint"
- Bump version of JavaDoc plugin to the latest > 3
- Remove the JavaDoc plugin's declaration from the build plugins used for default builds (building without a profile)
- Bump version of source plugin to latest > 3

- Remove unnecessary profile "doc" from the jclouds pom artifact

16 months agoRemove distribution profiles
gurkerl83 [Sun, 6 Dec 2020 23:47:02 +0000 (00:47 +0100)] 
Remove distribution profiles

Remove distribution profiles from the JClouds parent, main, and core modules. Each profile defines assembly descriptors, but none of those files are provided by the project anymore.
The maven assembly plugin relies on those descriptors to dictate its execution.
The estimation is that individual maven artifacts, one per module, get deployed instead of a compressed deployment unit.
In that case, it is enough to use mavens deploy command in combination with distribution management configuration pushing individual jars to the artifact repositories.

16 months agoRemove jenkins profile
gurkerl83 [Sun, 6 Dec 2020 23:25:55 +0000 (00:25 +0100)] 
Remove jenkins profile

According to the Jenkins configuration, only the maven profiles src and doc are necessary to execute in the build process. This commit removes the dedicated jenkins profile.

16 months agoRemove site profile and wired enforcer executions
gurkerl83 [Sun, 6 Dec 2020 21:24:44 +0000 (22:24 +0100)] 
Remove site profile and wired enforcer executions

The site profile defines various enforcer execution rules, banned-dependencies, java (java and maven version). Those declarations in combination with the standard maven properties for the JDK version seem misleading and duplicated. Also, there is no indicator that the site profile is ever defined for a maven build.

16 months agoRemove maven property site url
gurkerl83 [Sun, 6 Dec 2020 20:18:23 +0000 (21:18 +0100)] 
Remove maven property site url

In the last three commits, the site reporting feature got gradually decommissioned. This commit removes any remaining fragments in this regard. Remove the section distribution management from the profile clouds-project. The comment about incorrect links generated might have resulted from multiple invocations of the check style plugin. Previously the check style plugin got utilized at multiple sections (reporting section and profiles) and probably overlapping maven lifecycles.

16 months agoRemove section reporting
gurkerl83 [Sun, 6 Dec 2020 20:06:01 +0000 (21:06 +0100)] 
Remove section reporting

In the last two commits, the site reporting feature got gradually decommissioned. The maven plugin project-info-reports got removed in the previous commit, which gets controlled by the reporting section. Because this workflow is out of use, this commit removes the reporting section.

16 months agoRemove maven site deployment related plugins
gurkerl83 [Sun, 6 Dec 2020 19:44:30 +0000 (20:44 +0100)] 
Remove maven site deployment related plugins

The previous site plugin utilizes several plugins. In about half of the cases, the respective version of a plugin as described in the outside plugin section. The following list enumerates those plugins and my reasoning to remove them safely from the section plugins.

- maven-project-info-reports-plugin (remove - because no reports get generated)
- maven-javadoc-plugin (stays - even when a profile doc exists, which provides a dedicated setup.) We have to discuss the removal to avoid any side effects.
- emma-maven-plugin (stays - my impression is that it is a duplicated declaration)
- maven-jxr-plugin (remove - only version declaration, with no further config, not utilized anywhere)
- maven-surefire-report-plugin (remove - only version declaration, with no further config, not utilized anywhere)
- apache-rat-plugin (stays - decision is straightforward. We have to discuss a restructure because the plugin gets mentioned three times; I guess one can get removed.
- maven-pmd-plugin (remove - only version declaration, with no further config, not utilized anywhere)
- spotbugs-maven-plugin (stays - beacuse of its extended configuration section - discuss a removal)

16 months agoRemove maven site deployment
gurkerl83 [Sun, 6 Dec 2020 19:06:06 +0000 (20:06 +0100)] 
Remove maven site deployment

The maven site-plugin uses the declaration "site" in the section "distribution management," which points to a git repository named "jclouds-maven-site." This git repository got never relocated during the apache migration; also, it is ancient. My impression is that the site deployment is outdated and got used in the early days of JClouds.

16 months agoUpgrade OKHttp dependency
gurkerl83 [Wed, 3 Feb 2021 12:16:57 +0000 (13:16 +0100)] 
Upgrade OKHttp dependency

The JClouds project module upgrades the okhttp server library and related dependencies such as mockwebserver from 2.2.0 to 3.14.9. The vendor switched the groupId declaration from com.squareup.okhttp to com.squareup.okhttp3.

Adjust imports and api calls for newer okhttp vers

16 months agoRemove explicit OSGi import range of okio dep
gurkerl83 [Wed, 3 Feb 2021 21:55:29 +0000 (22:55 +0100)] 
Remove explicit OSGi import range of okio dep

All OkHttp components get shipped with any OSGi metadata. Tracking the progress of that issue from version 5 onwards, OkHttp finally provides OSGi support. Because JClouds OkHttp dependencies got renewed from 2.2.0 to the latest 3 (3.14.9), the respective bundles from Apache Servicemix got used in a deployment scenario. On the other hand, the problem with Servicemix is that there is no full match of published OkHttp dependencies to the respective bundle equivalent.

https://mvnrepository.com/artifact/org.apache.servicemix.bundles/org.apache.servicemix.bundles.okhttp

My test shows that none of the version 3 bundles work because of a missing package dependency "javax.annotation.meta". Sure higher version of 9 strips the javax.annotation module entirely, but the meta package is not there in JDK 8 either. As you can see from the link above, only two versions of 3.14 got published in the service mix; it is not clear to which version the bundle equivalents relate. From my understanding, it is much more important to use identical versions of OkHttp dependencies used in JClouds.

To utilize the original OKHttp libraries, consumer projects have to ensure those libraries get loaded using OSGi helper tools such as the wrap protocol provided by Apache Karaf or similar.

To reduce OSGi noise, I removed the OSGi import range of okio dependency entirely. A declaration like that does not make sense; otherwise, a set of Okhttp ranges must also be defined.

Note: The wildcard (*) declaration provides a way out, which allows any version of a package used in JClouds but itself does not give any OSGi metadata. Hopefully, I do not confuse you too much.

16 months agoClear rule for bouncycastle exclusion
gurkerl83 [Wed, 3 Feb 2021 20:56:53 +0000 (21:56 +0100)] 
Clear rule for bouncycastle exclusion

- Mock-Webserver v2.2.0 - Vendor, defined dependency bcprov-jdk15on > Previously, the dependency got excluded; otherwise, it conflicted with the existing bouncy castle version used in JClouds.
- Mock-Webserver v3.14.9 - The vendor does not define a bouncy castle dependency anymore; instead, it moved to the okhttp-tls module.

- Introduce the okhttp-tls module for tests in the core module. The following APIs (Docker, Elastic-Stack) and providers Softlayer extend their respective MockTest from BaseMockWebServerTest. The mock base test is located in the test jar of JClouds core module.
- Due to conflicting bouncy castle classes in the classpath, those which get loaded from the okhttp-tls module, and those defined in JClouds bouncy castle module, the bouncy castle dependency of okhttp-tls has to get skipped for the two APIs and providers mentioned.

Side note:
The JClouds GAE driver module also requires the new okhttp-tls dependency because of the following chain of inheritance.
Different from the situation above, the bouncy castle classes of the okhttp-tls got not excluded.
GaeHttpCommandExecutorServiceIntegrationTest -> BaseHttpCommandExecutorServiceIntegrationTest -> BaseMockWebServerTest

The reason for this is unknown to me.

16 months agolost changes
korlov42 [Sat, 10 Oct 2020 06:30:14 +0000 (09:30 +0300)] 
lost changes

16 months agofix failed testSSLConnectionFailsIfOnlyHttpConfigured
korlov42 [Fri, 9 Oct 2020 20:25:48 +0000 (23:25 +0300)] 
fix failed testSSLConnectionFailsIfOnlyHttpConfigured

16 months agofix UnsupportedOperationException during setting socketFactory
korlov42 [Fri, 9 Oct 2020 17:24:11 +0000 (20:24 +0300)] 
fix UnsupportedOperationException during setting socketFactory

16 months agoJCLOUDS-1551: Update version of OkHttp 3.14.9
korlov42 [Tue, 6 Oct 2020 15:38:30 +0000 (18:38 +0300)] 
JCLOUDS-1551: Update version of OkHttp 3.14.9

16 months agoForce application/x-directory for directories
Andrew Gaul [Tue, 2 Feb 2021 13:56:51 +0000 (22:56 +0900)] 
Force application/x-directory for directories

Paths created by Files.createParentDirs lack extended attributes and
thus Content-Type for directories.

17 months agoAllow setting BlobAccess in LocalBlobStore.putBlob
Andrew Gaul [Sun, 31 Jan 2021 13:27:14 +0000 (22:27 +0900)] 
Allow setting BlobAccess in LocalBlobStore.putBlob

This addresses a race condition with filesystem users.

17 months agoAdd OSGi version ranges, guice, okio
gurkerl83 [Sat, 9 Jan 2021 18:25:53 +0000 (19:25 +0100)] 
Add OSGi version ranges, guice, okio

In the present feature, the two properties
- guava.osgi.import and
- okhttp.version
have not been attached to the build process (Bnd plugin), but have been recorded as comments only.

Before the resolution method is considered, the problem of Guava and its close coupling with Guice must be examined.

The Guice project possesses, differently to GSON no explicit configuration, how its dependencies are regarded in an OSGi execution environment.

Guice / Guava
- 4.1.0 / 19.0
- 4.2.0 /  [23.6,24)
- 4.2.1 / [25.1,26)
- 4.2.3 / [27.1,28) => used
- 5.0.0.BETA-1 / [27.1,28)

The version of Guice built into JClouds is 4.2.3. Increasing to this version number was not the subject of the current branch.

To avoid backward compatibility problems between Guice and Guava (e.g. Guice 4.2.3 -> Guava 24) this means that the version of Guava integrated in JClouds must be at least version 27.1. Guice puts this in its dependencies.

In my opinion, consumers (JClouds, as well as consumers of JClouds) should take this minimum barrier into account.

Resolution
To understand the resolution, please consider the following previously unmerged feature.
https://github.com/apache/jclouds/pull/86

In order to add a Guava verison range to the bundles rolled out by JClouds, the following import rule is added in the BND Configuration of the Project Module.

Import Package: \
    com.google.common.*;version="[27.1,30.1.0)", \
    okio.*;version="[1.2.0,1.3)", \
    *

In the output of each JClouds module that uses Guava (and there are some) the configuration to the range version is observed. The bnd built into the JClouds project modules acts as a base of other bnd configurations, and should also apply in the Lab and Co repositories. Adjusted artefacts only become valid when a release is available or the build of these repositories is triggered again.

Output - Core Module

Import package:
   com.google.common.base;version="[27.1,30.1.0)",
   com.google.common.cache;version="[27.1,30.1.0)",
   com.google.common.collect;version="[27.1,30.1.0)",
   ...
   com.google.gson;version="[2.8,3)",
   ...

Output - Blobstore Module

Import package:
   com.google.common.base;version="[27.1,30.1.0)",
   com.google.common.collect;version="[27.1,30.1.0)",
   com.google.common.hash;version="[27.1,30.1.0)",
   ...
   com.google.inject;version="[1.4,2)",
   ...

Oki version range
The okhttp dependency requires okio version 1.2. The ok* libraries respectively the dependencies used in these libraries do not have OSGi instructions. For this reason, the previously integrated configuration is used.

Local tests show that the import directive can also be set globally, see above. An explicit specification in the bnd file of the JClouds okHTTP module is not useful because this JClouds module also uses Guava.

Output - OkHTTP Module

Import package:
   com.google.common.base;version="[27.1,30.1.0)",
   com.google.common.collect;version="[27.1,30.1.0)",
   okio;version="[1.2.0,1.3)",
   com.google.inject;version="[1.4,2)",
   ...

Note:
In the following feature, the version of the "ok" framework has been significantly increased.  Extensive adjustments are also performed.

At this point, it should be noted that the import policy in the okio will probably have to be removed again because standalone OSGi metadata may be provided.

17 months agoMove from OSGi Spec V4.2 to V6
gurkerl83 [Mon, 26 Oct 2020 15:08:53 +0000 (16:08 +0100)] 
Move from OSGi Spec V4.2 to V6

Increase of OSGi dependencies core and compendium (now cmpn) from 4.2 to 6.0.
Previously it was possible to run JClouds in OSGi environments from version 4.

An essential aspect to use JClouds in an OSGi environment requires so-called feature sets. These can be generated manually or automatically - see JClouds-Karaf project. Since there have been significant changes in the structure and behaviour of Karaf in the meantime, an adaptation is appropriate.

Breaking change - probably not, as no other APIs of core and compendium are used than up to now.

OSGi - V4.2 - Karaf 2.2.x - to 2.2.9 (Current Status - not active)
OSGi - V6.0 - Karaf 4.1.x - 4.2 (Current Status - active)

17 months agoRemove duplicated finder exception for cloudsigma
gurkerl83 [Mon, 26 Oct 2020 14:34:29 +0000 (15:34 +0100)] 
Remove duplicated finder exception for cloudsigma

In the source code of JClouds cloudsigma as a keyword gets not used anywhere. In the JClouds-Lab project, cloudSigma is available both as an API and multiple provider modules. Because the project module from JClouds serves as a parent module for all JClouds-Labs modules, it seems reasonable to maintain those rules in the JClouds project module.

After inspecting the JClouds Lab source code, group artifact combinations of

<groupId>org.apache.jclouds.api</groupId>
<artifactId>cloudsigma</artifactId>

..., respectively

<groupId>org.apache.jclouds.provider</groupId><artifactId>cloudsigma-lvs</artifactId>

..., are not available.

Cloudsigma in Lab uses the following group artifact combinations, all with a "2" prefix.

<groupId>org.apache.jclouds.labs</groupId
<artifactId>cloudsigma (2)</artifactId>

<groupId>org.apache.jclouds.labs</groupId>
<artifactId>cloudsigma (2) -hnl</artifactId>

Loading those bundles into an OSGi runtime, a runtime collision happens because the API exports the identical packages as the provider modules.

Although this was the case in a previous version, it has since been corrected.

https://github.com/apache/jclouds-labs/commit/e7885359a7755ac5ad6298f35b7547a31e1c5548

This commit removes the exception handling.

17 months agoReorder dependencies for core module
gurkerl83 [Mon, 26 Oct 2020 13:58:39 +0000 (14:58 +0100)] 
Reorder dependencies for core module

Reorder dependencies, integrate library javax.ws.rs-api in the parents' dependency management section

17 months agoRemove javax libraries
gurkerl83 [Mon, 26 Oct 2020 13:42:10 +0000 (14:42 +0100)] 
Remove javax libraries

Remove javax libraries inject and annotation. In JDK 8 those libraries are provided by the JDK. Younger JDK versions > 11 exclude them again to make the JDK leaner. Supporting younger JDK versions means integrating more younger libraries maintained by the Jakarta project.

17 months agoRemove Guice multibindings
gurkerl83 [Mon, 26 Oct 2020 13:28:56 +0000 (14:28 +0100)] 
Remove Guice multibindings

Since Guice 4.2, multibindings support has moved to Guice core. Before that, you need to depend on the guice-multibindings extension. For reference https://github.com/google/guice/wiki/Multibindings

17 months agoInitial cleanup of maven set up in the parents' module
gurkerl83 [Mon, 26 Oct 2020 13:20:51 +0000 (14:20 +0100)] 
Initial cleanup of maven set up in the parents' module

- Increase version of Guava dependency from 22.0 to 27.1-jre.

Note: In an OSGi runtime, Guice version 4.2.3 expects Guava with an exact version of 27.1-jre. For now, higher versions of Guava are not possible.

- Separate version numbers from dependencies and plugins

Following is a description of the purpose of the feature.

New contributors find it difficult to understand the function and intent of different plugins integrated into JClouds.

The primary goal is to simplify and streamline the overall setup.

On closer examination of the integrated plugins you will notice that,

- different plugins are used for the same or a similar goal
- the development activity of used plugins has been terminated
- modified integration requirements through Maven. The development of used plugins is progressing. Versions of the plugins integrated into JClouds are not up to date. Newer plugin versions require an adjustment to how integration into a project is done.

Basically the setup of the plugins used in the Maven project POM was done a long time ago. The project POM file of the JClouds project serves as a parent for all modules in JClouds.

The first step is to consolidate the used plugins.

The same aspects apply to the build profiles used in the project. On closer look these must be considered obsolete. A deconstruction of declared build profiles is aimed at.

In order to support newer runtime environments, for example JDK11 and above, we aim to integrate build profiles.

In the respective build profile the libraries which are no longer contained in the respective target JDK but needed in JClouds are to be integrated.

In the course of this rebuild, a property-based way of declaring the version number of dependencies and plugins will be implemented.

17 months agoSimplify S3 code that uses java-xml-builder (#93)
Jean-Noël Rouvignac [Thu, 21 Jan 2021 12:54:44 +0000 (13:54 +0100)] 
Simplify S3 code that uses java-xml-builder (#93)

* animal sniffer should be on java18, just like `<jdk.version>`

* Only use XMLBuilder's elem() and text() methods to have similar looking code

* Remove unnecessary call to XMLBuilder's up() because the returned value is never used

* Simplify code

* Deduplicate code

* Make the code more explicit by returning the rootBuilder

18 months agoJCLOUDS-1557 - Azure local server support
davidsloan [Tue, 8 Dec 2020 02:14:03 +0000 (02:14 +0000)] 
JCLOUDS-1557 - Azure local server support

Co-authored-by: David Sloan <david.sloan@lenses.io>
18 months agoSync OSGi handling with Apache JClouds Project
gurkerl83 [Sun, 6 Dec 2020 13:51:14 +0000 (14:51 +0100)] 
Sync OSGi handling with Apache JClouds Project

This project, the aws-lab version of Apache JClouds, share the exact build instructions as the primary Apache JClouds project with all its modules.
Apache JClouds is shifting its strategy in handling OSGi configuration. Instead of using the Maven Bundle Plugin, a wrapper of the BND plugin, the BND plugin gets used directly.
- Remove the OSGi configuration from each module. The configuration gets served to the BND through dedicated configuration / bnd files.
- Onboard bnd-configuration files, one per module.

Ignore bnd files in rat plugin

18 months agoJCLOUDS-1559: add Charset to Json.fromJson InputStream methods
roded [Fri, 4 Dec 2020 19:56:24 +0000 (21:56 +0200)] 
JCLOUDS-1559: add Charset to Json.fromJson InputStream methods

20 months agoRemove scope declaration from deps management
gurkerl83 [Mon, 26 Oct 2020 00:33:49 +0000 (01:33 +0100)] 
Remove scope declaration from deps management

The default scope of imports is "compile." There is no reason to add this declaration to the GSON import declaration. Also, scope declarations are required to be defined in the main dependency declaration section, not in dependency management, where dependency information gets managed, which is valid across all of its children, e.g., version numbers.

20 months agoLowering the GSON version
gurkerl83 [Mon, 26 Oct 2020 00:22:49 +0000 (01:22 +0100)] 
Lowering the GSON version

Lowering the GSON version from 2.8.6 (latest) to 2.8.5, to make sure no side effects get introduced on a JDK level - for reference https://github.com/google/gson/issues/1601. Another feature is in its making to introduce a conditional build profile to support JDK 11 and above; here, a switch to the latest version of GSON gets provided.

20 months agoIn the final state of this feature, a rebase on Master was executed. In resolving...
gurkerl83 [Sat, 24 Oct 2020 15:48:40 +0000 (17:48 +0200)] 
In the final state of this feature, a rebase on Master was executed. In resolving a merge problem with the Maven project file "JClouds Project," an important instruction got overwritten, to generate test jars for each module. This modification re-adds this ability for all modules. Counter versa, defining this build step repeatedly, e.g., in the api/oauth module, is no longer required. Also, correct a typo, add groupId.

Note: Previously, the maven jar plugin contained a configuration embedded in each module's generated manifest files. The configuration got relocated to the project/bnd.bnd file in a previous commit, and gets handled through the bnd plugin.

20 months agoIn the final state of this feature a rebase on Master was executed. In resolving...
gurkerl83 [Sat, 24 Oct 2020 12:32:04 +0000 (14:32 +0200)] 
In the final state of this feature a rebase on Master was executed. In resolving a merge problem with the Maven project file "JClouds Project", an important change already introduced in Master was overlooked. The library Guice was already updated to the latest version 4.2.3 in Master, and the original version number 3.0 was accidentally added to the Maven project file. This modification removes the version number 3.0 from the configuration.

20 months agoRe-Enable the build for all modules. Increase version of bnd plugin to the latest.
gurkerl83 [Sat, 17 Oct 2020 14:04:22 +0000 (16:04 +0200)] 
Re-Enable the build for all modules. Increase version of bnd plugin to the latest.

20 months agoRemove the OSGi configuration from each module. The approach of defining OSGi configu...
gurkerl83 [Sat, 17 Oct 2020 14:01:26 +0000 (16:01 +0200)] 
Remove the OSGi configuration from each module. The approach of defining OSGi configuration through common properties and serving them to the bundle plugin gets no longer used; instead, OSGi configuration gets defined in each module's dedicated bnd file.

20 months agoOnboard bnd-configuration files, one per module
gurkerl83 [Sat, 17 Oct 2020 13:44:37 +0000 (15:44 +0200)] 
Onboard bnd-configuration files, one per module

20 months agoIntegrate GSON library in Clouds Core Bundle Final
gurkerl83 [Thu, 2 Jul 2020 08:54:28 +0000 (10:54 +0200)] 
Integrate GSON library in Clouds Core Bundle Final

In the last commit (last section of squashed commit), the GSON library was integrated into the JClouds core module using maven-bundle plugins include resource instruction. Building OSGi instruction variables from the respective modules show a weakness when resources such as script builder shell scripts are required to be integrated into the bundle but not provide a dedicated variable declaration for the resource section.

The following commit demonstrates a change in strategy in declaration and integration of OSGi metadata.

- Replace old bundle-plugin with newest bnd-plugin (bundle-plugin uses bnd-plugin internally)
- Move OSGi metadata declarations from a maven variable passing strategy into dedicated bnd.bnd files
+ Cleaner pom files, no bundle packaging
+ Intellisense / Autocomplete support for .bnd files in terms of package exports etc.

For demonstration, the overall OSGi adjustments are limited to project, core, script builder, compute, blob store, and load balancer because most custom OSGi metadata is defined here.

Note: Other modules are currently disabled from build because some feedback is needed first.

Make GSON integration work.
To understand the changes, see the core modules' bnd file. GSON internal packages also define a version. Both already exported and new export declarations are fused. The global JClouds core module exports defined the entire set of GSON packages available.

Some minor modifications were made in the module project; replace maven jar plugin with a minified version of the declaration, outsourced in projects bnd file.

20 months agoReplace embedded and repackaged GSON library
gurkerl83 [Thu, 25 Jun 2020 13:27:15 +0000 (15:27 +0200)] 
Replace embedded and repackaged GSON library

Replace substituted GSON package names with those provided from the vendor.
Reduce OSGi-metadata declaration of core-module because the artificial package org.jclouds.json.gson.internal was removed.
Remove the Gson module its children Gson bundle, and Gson shaded.
Remove duplication conflict and check-style rules due to the removal of the internal Gson module.
Add maven repository where a custom version of the Gson library gets hosted, which exports all packages.

Remove particular repository

Remove the declaration of the repository that serves a custom build GSON version. The build uses GSON in its original form of the vendor, which gets distributed through the standard distribution channel. The identifiers for group, artifact, and version correspond to the latest stable release of GSON.

Integrate GSON library in Clouds Core Bundle

The change contained in the commit puts the GSON library into the classpath of the JClouds core module.
After several tests with Karaf and Karaf JClouds, especially if the Maven identifier matches the original GSON library, there are only a limited number of ways to keep the deployment effort low.

Specifically, Karaf has a set of predefined Maven repositories that can be easily customized. The order in which a particular repository is resolved into the customized GSON library is more difficult. In normal OSGi applications, which do not have such a management function, I imagine this configuration to be more complicated.  Sure, a unique identifier would help, but then we are back to step 1.

Although I honestly don't like to see this kind of approach in a codebase I'm working with, there are not many alternatives to the main aspect of deployment mentioned above.

Maybe the approach can still ease the problem in the short term. In a further mid-term step, however, this problem must be addressed in general.

20 months agoRemove unintended executable permissions
Andrew Gaul [Fri, 9 Oct 2020 14:33:41 +0000 (23:33 +0900)] 
Remove unintended executable permissions

Fixed via:

find -executable -not -type d -name \*.java -exec chmod -x {} \;

21 months agoJCLOUDS-1498: Upgrade to Guice 4.2.3
Andrew Gaul [Sat, 26 Sep 2020 01:34:31 +0000 (10:34 +0900)] 
JCLOUDS-1498: Upgrade to Guice 4.2.3

Release notes:

https://github.com/google/guice/wiki/Guice423

21 months agoJCLOUDS-1552: Do not attempt to parse empty payload (#82)
Tamas Cservenak [Mon, 21 Sep 2020 13:46:25 +0000 (15:46 +0200)] 
JCLOUDS-1552: Do not attempt to parse empty payload (#82)

23 months agoOptimize MultiBlobInputStream.read()
Andrew Gaul [Sat, 25 Jul 2020 07:39:04 +0000 (16:39 +0900)] 
Optimize MultiBlobInputStream.read()

Previously this allocated a byte array for every call.

23 months agoJCLOUDS-1367: Do not open open InputStream in copyBlob
Andrew Gaul [Sat, 25 Jul 2020 07:34:46 +0000 (16:34 +0900)] 
JCLOUDS-1367: Do not open open InputStream in copyBlob

This avoids an unneeded call to ByteStreams2.toByteArrayAndClose in
getBlob for range requests and elides a large memory allocation.

23 months agoStore transient Blob data with ByteArrayPayload
Andrew Gaul [Sat, 11 Jul 2020 19:53:37 +0000 (04:53 +0900)] 
Store transient Blob data with ByteArrayPayload

This avoids a race condition due to sharing the same Closer instance
and unbounded growth of its Closeable Deque.  References
gaul/s3proxy#303.

23 months agoJCLOUDS-1542 follow-up: check whether isAccessible() is already set (#79)
Jean-Noël Rouvignac [Sun, 5 Jul 2020 21:33:07 +0000 (23:33 +0200)] 
JCLOUDS-1542 follow-up: check whether isAccessible() is already set (#79)

AccessibleObject.canAccess() would be much much better,
but this API can only be used from Java 9 onward.

2 years agoJCLOUDS-1542 Java 11 warns of illegal reflective access (#76)
Jean-Noël Rouvignac [Fri, 26 Jun 2020 17:55:32 +0000 (19:55 +0200)] 
JCLOUDS-1542 Java 11 warns of illegal reflective access (#76)

With Java 11, an illegal reflective access is output for the google cloud storage blobstore.

    WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.jclouds.reflect.Reflection2$1 (file:/.../jclouds-core.jar) to constructor java.lang.String(char[],int,int,java.lang.Void)
    WARNING: Please consider reporting this to the maintainers of org.jclouds.reflect.Reflection2$1
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release

Indeed, JClouds calls `setAccessible(true)` on the package protected constructor
     `java.lang.String(char[],int,int,java.lang.Void)`.
Investigating the code, it turns out it is looking for constructors annotated with any of:
* java.beans.ConstructorProperties
* org.jclouds.json.SerializedNames
* com.google.inject.Inject

But `String` being defined in `java.base` module, it is impossible
     that it will be annotated with any of these annotation.

This commit is complementary to JClouds commit db4e4af931ef19f582b85f02efb93e50f1c5d01c .

&nbsp;

Reflection2.java:
Do not call `setAccessible(true)` on core java constructors and methods.

&nbsp;

For reference, here is the stacktrace of this illegal access warning:

    java.lang.String.<init>(String.java:3208)
    java.lang.String.<init>(String.java:251)
    java.util.StringJoiner.compactElts(StringJoiner.java:250)
    java.util.StringJoiner.toString(StringJoiner.java:173)
    jdk.internal.module.IllegalAccessLogger.loudWarning(IllegalAccessLogger.java:339)
    jdk.internal.module.IllegalAccessLogger.log(IllegalAccessLogger.java:288)
    jdk.internal.module.IllegalAccessLogger.log(IllegalAccessLogger.java:261)
    jdk.internal.module.IllegalAccessLogger.logIfOpenedForIllegalAccess(IllegalAccessLogger.java:226)
    java.lang.reflect.AccessibleObject.logIfOpenedForIllegalAccess(AccessibleObject.java:366)
    java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:325)
    java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:280)
    java.lang.reflect.Constructor.checkCanSetAccessible(Constructor.java:189)
    java.lang.reflect.Constructor.setAccessible(Constructor.java:182)
    org.jclouds.reflect.Reflection2$1.load(Reflection2$1.java:157)
    org.jclouds.reflect.Reflection2$1.load(Reflection2$1.java:153)
    com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache$LoadingValueReference.java:3529)
    com.google.common.cache.LocalCache$Segment.loadSync(LocalCache$Segment.java:2278)
    com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache$Segment.java:2155)
    com.google.common.cache.LocalCache$Segment.get(LocalCache$Segment.java:2045)
    com.google.common.cache.LocalCache.get(LocalCache.java:3953)
    com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:3976)
    com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache$LocalLoadingCache.java:4960)
    org.jclouds.reflect.Reflection2.get(Reflection2.java:346)
    org.jclouds.reflect.Reflection2.constructors(Reflection2.java:100)
    org.jclouds.json.internal.NamingStrategies$AnnotationConstructorNamingStrategy.getDeserializer(NamingStrategies$AnnotationConstructorNamingStrategy.java:271)
    org.jclouds.json.internal.DeserializationConstructorAndReflectiveTypeAdapterFactory.create(DeserializationConstructorAndReflectiveTypeAdapterFactory.java:125)
    com.google.gson.Gson.getAdapter(Gson.java:458)
    org.jclouds.json.gson.internal.bind.ReflectiveTypeAdapterFactory.createBoundField(ReflectiveTypeAdapterFactory.java:117)
    org.jclouds.json.gson.internal.bind.ReflectiveTypeAdapterFactory.getBoundFields(ReflectiveTypeAdapterFactory.java:166)
    org.jclouds.json.gson.internal.bind.ReflectiveTypeAdapterFactory.create(ReflectiveTypeAdapterFactory.java:102)
    com.google.gson.Gson.getAdapter(Gson.java:458)
    com.google.gson.Gson.toJson(Gson.java:696)
    com.google.gson.Gson.toJson(Gson.java:683)
    com.google.gson.Gson.toJson(Gson.java:638)
    com.google.gson.Gson.toJson(Gson.java:618)
    org.jclouds.json.internal.GsonWrapper.toJson(GsonWrapper.java:65)
    org.jclouds.oauth.v2.functions.ClaimsToAssertion.apply(ClaimsToAssertion.java:59)
    org.jclouds.oauth.v2.functions.ClaimsToAssertion.apply(ClaimsToAssertion.java:43)
    org.jclouds.rest.internal.RestAnnotationProcessor.getParamValue(RestAnnotationProcessor.java:829)
    org.jclouds.rest.internal.RestAnnotationProcessor.getFormParamKeyValues(RestAnnotationProcessor.java:847)
    org.jclouds.rest.internal.RestAnnotationProcessor.addFormParams(RestAnnotationProcessor.java:435)
    org.jclouds.rest.internal.RestAnnotationProcessor.apply(RestAnnotationProcessor.java:258)
    org.jclouds.rest.internal.RestAnnotationProcessor.apply(RestAnnotationProcessor.java:137)
    org.jclouds.rest.internal.InvokeHttpMethod.toCommand(InvokeHttpMethod.java:189)
    org.jclouds.rest.internal.InvokeHttpMethod.invoke(InvokeHttpMethod.java:85)
    org.jclouds.rest.internal.InvokeHttpMethod.apply(InvokeHttpMethod.java:74)
    org.jclouds.rest.internal.InvokeHttpMethod.apply(InvokeHttpMethod.java:45)
    org.jclouds.rest.internal.DelegatesToInvocationFunction.handle(DelegatesToInvocationFunction.java:156)
    org.jclouds.rest.internal.DelegatesToInvocationFunction.invoke(DelegatesToInvocationFunction.java:123)
    com.sun.proxy.$Proxy49.authorize(Unknown Source)
    org.jclouds.oauth.v2.filters.JWTBearerTokenFlow$AuthorizeToken.load(JWTBearerTokenFlow$AuthorizeToken.java:84)
    org.jclouds.oauth.v2.filters.JWTBearerTokenFlow$AuthorizeToken.load(JWTBearerTokenFlow$AuthorizeToken.java:68)
    com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache$LoadingValueReference.java:3529)
    com.google.common.cache.LocalCache$Segment.loadSync(LocalCache$Segment.java:2278)
    com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache$Segment.java:2155)
    com.google.common.cache.LocalCache$Segment.get(LocalCache$Segment.java:2045)
    com.google.common.cache.LocalCache.get(LocalCache.java:3953)
    com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:3976)
    com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache$LocalLoadingCache.java:4960)
    com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache$LocalLoadingCache.java:4966)
    org.jclouds.oauth.v2.filters.JWTBearerTokenFlow.filter(JWTBearerTokenFlow.java:99)
    org.jclouds.http.internal.BaseHttpCommandExecutorService.invoke(BaseHttpCommandExecutorService.java:90)
    org.jclouds.rest.internal.InvokeHttpMethod.invoke(InvokeHttpMethod.java:91)
    org.jclouds.rest.internal.InvokeHttpMethod.apply(InvokeHttpMethod.java:74)
    org.jclouds.rest.internal.InvokeHttpMethod.apply(InvokeHttpMethod.java:45)
    org.jclouds.reflect.FunctionalReflection$FunctionalInvocationHandler.handleInvocation(FunctionalReflection.java:117)
    com.google.common.reflect.AbstractInvocationHandler.invoke(AbstractInvocationHandler.java:86)
    com.sun.proxy.$Proxy54.simpleUpload(Unknown Source)
    org.jclouds.googlecloudstorage.blobstore.GoogleCloudStorageBlobStore.uploadMultipartPart(GoogleCloudStorageBlobStore.java:422)
    org.jclouds.blobstore.internal.BaseBlobStore$BlobUploader.call(BaseBlobStore.java:415)
    org.jclouds.blobstore.internal.BaseBlobStore$BlobUploader.call(BaseBlobStore.java:402)
    com.google.common.util.concurrent.TrustedListenableFutureTask$TrustedFutureInterruptibleTask.runInterruptibly(TrustedListenableFutureTask.java:125)
    com.google.common.util.concurrent.InterruptibleTask.run(InterruptibleTask.java:69)
    com.google.common.util.concurrent.TrustedListenableFutureTask.run(TrustedListenableFutureTask.java:78)
    java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
    java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor$Worker.java:628)
    java.lang.Thread.run(Thread.java:834)

2 years agoJCLOUDS-1333: Fix Guava 21 issues
Andrew Gaul [Thu, 25 Jun 2020 10:26:46 +0000 (19:26 +0900)] 
JCLOUDS-1333: Fix Guava 21 issues

2 years agoJCLOUDS-1473 add INTELLIGENT_TIERING enum
Sam Ottenhoff [Wed, 24 Jun 2020 15:29:15 +0000 (11:29 -0400)] 
JCLOUDS-1473 add INTELLIGENT_TIERING enum

2 years agoDisable doclint during Jenkins build
Andrew Gaul [Wed, 24 Jun 2020 23:37:25 +0000 (08:37 +0900)] 
Disable doclint during Jenkins build

Now that we require Java 8 we do not need this workaround.

2 years agoJCLOUDS-1333: JCLOUDS-1334: JCLOUDS-1470: Require Java 8 and Guava 22
Andrew Gaul [Sun, 14 Jun 2020 02:40:04 +0000 (11:40 +0900)] 
JCLOUDS-1333: JCLOUDS-1334: JCLOUDS-1470: Require Java 8 and Guava 22

This allows compatibility with Guava 29.  Also unwind some older
workarounds.

2 years agoJCLOUDS-1491 Jclouds uses a deprecated version of Guava to support Azure storage
Jean-Noël Rouvignac [Tue, 2 Jun 2020 13:29:02 +0000 (15:29 +0200)] 
JCLOUDS-1491 Jclouds uses a deprecated version of Guava to support Azure storage

DnsNameValidator.java uses a deprecated guava APIs in code that is used
 to support Azure cloud storage. When forcing the use of more recent guava
 versions, the code fails with NoSuchFieldError.

However, CharMatcher.JAVA_LETTER_OR_DIGIT has been removed in guava 26.0,
 and CharMatcher.javaLetterOrDigit() should be used instead since guava
 19.0. Note that CharMatcher.javaLetterOrDigit() was immediately
 deprecated in Guava 26.0, and java.lang.Character.isLetterOrDigit(int)
 should be used instead.

This commit replaces the use of this deprecated API by
 java.lang.Character.isLetterOrDigit(int).
 It is no worse than the previous code.

(If I understand correctly, updating the guava version is a challenge due to
dependencies on Apache Karaf anyway)

2 years agoJCLOUDS-912: JCLOUDS-1547: GCS InputStream single-part upload
Andrew Gaul [Sat, 23 May 2020 04:25:24 +0000 (13:25 +0900)] 
JCLOUDS-912: JCLOUDS-1547: GCS InputStream single-part upload

Previously this provider worked around a RestAnnotationProcessor quirk
by using multi-part uploads for InputStream payloads.  Instead work
around the quirk another way which allows a single-part upload.  This
allows inclusion of the Content-MD5 header during object creation.
Backfill tests with both ByteSource and InputStream inputs.

2 years agoJCLOUDS-1546: Support GCS Archive storage class
Andrew Gaul [Mon, 4 May 2020 11:25:53 +0000 (20:25 +0900)] 
JCLOUDS-1546: Support GCS Archive storage class

Also change portable abstraction mapping for Tier.ARCHIVE.

2 years agoJCLOUDS-1543: remove unused imports from FetchBlobMetadataTest.java (#70)
roded [Wed, 22 Apr 2020 07:49:53 +0000 (10:49 +0300)] 
JCLOUDS-1543: remove unused imports from FetchBlobMetadataTest.java (#70)

Co-authored-by: Roded Bahat <roded.bahat@model9.io>
2 years agoFix toolchain setup on jenkins (#68)
Fritz Elfert [Wed, 22 Apr 2020 07:56:36 +0000 (09:56 +0200)] 
Fix toolchain setup on jenkins (#68)

2 years agoJCLOUDS-1543: change FetchBlobMetadata to retain original blob order
Roded Bahat [Tue, 14 Apr 2020 17:17:33 +0000 (20:17 +0300)] 
JCLOUDS-1543: change FetchBlobMetadata to retain original blob order

2 years agoEnable docs in travis build (#69)
Fritz Elfert [Fri, 17 Apr 2020 06:26:50 +0000 (08:26 +0200)] 
Enable docs in travis build (#69)