Note that a javascript engine is required