[MSHARED-640] Upgrade maven-invoker-plugin to resolve IT failure on Windows
authorGuillaume Boué <gboue@apache.org>
Wed, 14 Jun 2017 19:00:22 +0000 (19:00 +0000)
committerGuillaume Boué <gboue@apache.org>
Wed, 14 Jun 2017 19:00:22 +0000 (19:00 +0000)
Fix failing IT on Windows. The current parent Apache POM defines version 2.0.0 for the maven-invoker-plugin, where the issue due to the rename of mvn.bat on Windows with Maven 3.3.1 is fixed. The project should inherit from it instead of forcing version 1.7.

git-svn-id: https://svn.apache.org/repos/asf/maven/shared/trunk@1798738 13f79535-47bb-0310-9956-ffa450edef68

pom.xml

diff --git a/pom.xml b/pom.xml
index 9190f3f..f5e2b64 100644 (file)
--- a/pom.xml
+++ b/pom.xml
@@ -172,7 +172,6 @@ under the License.
         <plugins>
           <plugin>
             <artifactId>maven-invoker-plugin</artifactId>
-            <version>1.7</version>
             <configuration>
               <debug>true</debug>
               <cloneProjectsTo>${project.build.directory}/it</cloneProjectsTo>