mentioning JUnit5 in usages.apt.vm
authorTibor17 <tibordigana@apache.org>
Mon, 10 Dec 2018 02:59:58 +0000 (03:59 +0100)
committerTibor17 <tibordigana@apache.org>
Mon, 10 Dec 2018 02:59:58 +0000 (03:59 +0100)
maven-surefire-plugin/src/site/apt/usage.apt.vm

index c442e67..6b7e706 100644 (file)
@@ -104,14 +104,14 @@ mvn verify
 
    * TestNG
 
-   * JUnit (3.8 or 4.x)
+   * JUnit (3.8, 4.x or 5.x)
 
    * POJO
 
   Which providers are available is controlled simply by the inclusion of the
-  appropriate dependencies (i.e., <<<junit:junit>>> or <<<junit:junit-dep>>> for JUnit and <<<org.testng:testng>>> 4.7+
-  for TestNG). Since this is required to compile the test classes anyway, no
-  additional configuration is required.
+  appropriate dependencies (i.e., <<<junit:junit>>> or <<<junit:junit-dep>>> for JUnit4, <<junit-jupiter-engine>> or
+  <<junit-vintage-engine>> for JUnit5 and <<<org.testng:testng>>> 4.7+ for TestNG). Since this is required to compile the test
+  classes anyway, no additional configuration is required.
 
   Note that any normal Surefire integration works identically no matter which
   providers are in use - so you can still produce a Cobertura report and a