SLING-7365 for unsupported java version fall back to Java 9
authorKonrad Windszus <kwin@apache.org>
Fri, 12 Jan 2018 13:05:27 +0000 (14:05 +0100)
committerRobert Munteanu <rombert@apache.org>
Mon, 15 Jan 2018 09:34:17 +0000 (11:34 +0200)
also upgrade to the latest Eclipse Java Compiler (with the right GAV)
shipped with Oxygen .2

This closes #1

pom.xml
src/main/java/org/apache/sling/commons/compiler/impl/EclipseJavaCompiler.java

diff --git a/pom.xml b/pom.xml
index 6996c97..946895a 100644 (file)
--- a/pom.xml
+++ b/pom.xml
             <version>1.3.0</version>
             <scope>provided</scope>
         </dependency>
+        <!-- the correct GAV is referenced in https://bugs.eclipse.org/bugs/show_bug.cgi?id=499019#c19 -->
         <dependency>
-            <groupId>org.eclipse.jdt.core.compiler</groupId>
+            <groupId>org.eclipse.jdt</groupId>
             <artifactId>ecj</artifactId>
-            <version>4.6.1</version>
+            <version>3.13.100</version> <!-- this is the version shipped in Oxygen .2 -->
         </dependency>
         <dependency>
             <groupId>org.slf4j</groupId>
index 160bb6b..564b232 100644 (file)
@@ -26,6 +26,8 @@ import java.net.URL;
 import java.util.HashMap;
 import java.util.Locale;
 import java.util.Map;
+import java.util.Set;
+import java.util.concurrent.CopyOnWriteArraySet;
 
 import org.apache.sling.commons.classloader.ClassLoaderWriter;
 import org.apache.sling.commons.compiler.CompilationResult;
@@ -70,6 +72,8 @@ public class EclipseJavaCompiler implements JavaCompiler {
 
     /** the static policy. */
     private final IErrorHandlingPolicy policy = DefaultErrorHandlingPolicies.exitAfterAllProblems();
+    
+    private final Set<String> warningEmittedForUnsupportedJavaVersion = new CopyOnWriteArraySet<>();
 
     /**
      * Get the classloader for the compilation.
@@ -233,9 +237,15 @@ public class EclipseJavaCompiler implements JavaCompiler {
     }
 
     private String adjustJavaVersion(String javaVersion) {
-
-        // ECJ 4.6.1 expects Java version 1.9, not 9
-        return "9".equals(javaVersion) ? "1.9" : javaVersion;
+        // use latest supported version (Java 9) in case the given java version is not supported by ECJ yet
+        if (CompilerOptions.versionToJdkLevel(javaVersion) == 0) {
+            // only log once per invalid javaVersion
+            if (!warningEmittedForUnsupportedJavaVersion.contains(javaVersion) && warningEmittedForUnsupportedJavaVersion.add(javaVersion)) {
+                logger.warn("Using unsupported java version '{}', assuming latest supported version '{}'", javaVersion, CompilerOptions.VERSION_9);
+            }
+            return CompilerOptions.VERSION_9;
+        }
+        return javaVersion;
     }
 
     //--------------------------------------------------------< inner classes >