SLING-2815 - add explicit dependencies to make sure build works on empty local Maven...
authorBertrand Delacretaz <bdelacretaz@apache.org>
Tue, 9 Apr 2013 09:19:04 +0000 (09:19 +0000)
committerBertrand Delacretaz <bdelacretaz@apache.org>
Tue, 9 Apr 2013 09:19:04 +0000 (09:19 +0000)
git-svn-id: https://svn.apache.org/repos/asf/sling/trunk@1465939 13f79535-47bb-0310-9956-ffa450edef68

pom.xml

diff --git a/pom.xml b/pom.xml
index 90ef55f..08d582d 100644 (file)
--- a/pom.xml
+++ b/pom.xml
@@ -36,6 +36,8 @@
         <exam.version>3.0.3</exam.version>
         <url.version>1.5.2</url.version>
         <pax.exam.log.level>INFO</pax.exam.log.level>
+        <installer.api.version>1.0.1-SNAPSHOT</installer.api.version>
+        <installer.configuration.version>1.0.11-SNAPSHOT</installer.configuration.version>
 
         <!-- BundleInstallStressTest parameters -->
         <BundleInstallStressTest.default.bundles.folder>${project.build.directory}/bundle-install-stress-test-bundles</BundleInstallStressTest.default.bundles.folder>
                         </property>
                         <property>
                             <name>installer.api.version</name>
-                            <value>1.0.1-SNAPSHOT</value>
+                            <value>${installer.api.version}</value>
                         </property>
                         <property>
                             <name>installer.configuration.version</name>
-                            <value>1.0.11-SNAPSHOT</value>
+                            <value>${installer.configuration.version}</value>
                         </property>
                         <property>
                             <name>osgi.installer.base.dir</name>
             </plugin>
           </plugins>
     </build>
-
+    
     <dependencies>
         <dependency>
             <groupId>org.apache.sling</groupId>
             <artifactId>org.apache.sling.installer.api</artifactId>
-            <version>1.0.0</version>
+            <version>${installer.api.version}</version>
+            <scope>provided</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.sling</groupId>
+            <artifactId>org.apache.sling.installer.factory.configuration</artifactId>
+            <version>${installer.configuration.version}</version>
+            <scope>provided</scope>
+        </dependency>
+        <dependency>
+            <groupId>org.apache.sling</groupId>
+            <artifactId>org.apache.sling.installer.api</artifactId>
+            <version>${installer.api.version}</version>
             <scope>provided</scope>
         </dependency>
         <dependency>