SLING-3239 - Upgrade to SCR 1.8.0
authorRobert Munteanu <rombert@apache.org>
Mon, 11 Nov 2013 12:25:06 +0000 (12:25 +0000)
committerRobert Munteanu <rombert@apache.org>
Mon, 11 Nov 2013 12:25:06 +0000 (12:25 +0000)
Use org.apache.felix.scr in the launchpad/builder and also upgrade the
version referenced in integration tests.

git-svn-id: https://svn.apache.org/repos/asf/sling/trunk@1540694 13f79535-47bb-0310-9956-ffa450edef68

src/test/java/org/apache/sling/installer/it/OsgiInstallerTestBase.java

index 0bee2d3..8dad5e4 100644 (file)
@@ -407,7 +407,7 @@ class OsgiInstallerTestBase implements FrameworkListener {
                         mavenBundle("org.slf4j", "jcl-over-slf4j", "1.6.4"),
                         mavenBundle("org.slf4j", "log4j-over-slf4j", "1.6.4"),
 
-                           mavenBundle("org.apache.felix", "org.apache.felix.scr", "1.6.0"),
+                           mavenBundle("org.apache.felix", "org.apache.felix.scr", "1.8.0"),
                            mavenBundle("org.apache.felix", "org.apache.felix.configadmin", "1.2.8"),
                         mavenBundle("org.apache.felix", "org.apache.felix.metatype", "1.0.2"),
                                mavenBundle("org.apache.sling", "org.apache.sling.installer.core", POM_VERSION),
@@ -574,4 +574,4 @@ class OsgiInstallerTestBase implements FrameworkListener {
             }
         }
     }
-}
\ No newline at end of file
+}