[maven-release-plugin] prepare release org.apache.sling.models.impl-1.2.0
authorStefan Seifert <sseifert@apache.org>
Wed, 24 Jun 2015 07:59:52 +0000 (07:59 +0000)
committerStefan Seifert <sseifert@apache.org>
Wed, 24 Jun 2015 07:59:52 +0000 (07:59 +0000)
git-svn-id: https://svn.apache.org/repos/asf/sling/trunk/bundles/extensions/models/impl@1687190 13f79535-47bb-0310-9956-ffa450edef68

pom.xml

diff --git a/pom.xml b/pom.xml
index fb3e035..3d81a87 100644 (file)
--- a/pom.xml
+++ b/pom.xml
-<?xml version="1.0" encoding="ISO-8859-1"?>
-<!--
-  Licensed to the Apache Software Foundation (ASF) under one
-  or more contributor license agreements.  See the NOTICE file
-  distributed with this work for additional information
-  regarding copyright ownership.  The ASF licenses this file
-  to you under the Apache License, Version 2.0 (the
-  "License"); you may not use this file except in compliance
-  with the License.  You may obtain a copy of the License at
-
-   http://www.apache.org/licenses/LICENSE-2.0
-
-  Unless required by applicable law or agreed to in writing,
-  software distributed under the License is distributed on an
-  "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-  KIND, either express or implied.  See the License for the
-  specific language governing permissions and limitations
-  under the License.
--->
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
-    <modelVersion>4.0.0</modelVersion>
-    <parent>
-        <groupId>org.apache.sling</groupId>
-        <artifactId>sling</artifactId>
-        <version>22</version>
-        <relativePath/>
-    </parent>
-    <groupId>org.apache.sling</groupId>
-    <artifactId>org.apache.sling.models.impl</artifactId>
-    <packaging>bundle</packaging>
-    <version>1.1.1-SNAPSHOT</version>
-    <name>Apache Sling Models Implementation</name>
-    <description>Apache Sling Models Implementation</description>
-    <properties>
-        <sling.java.version>6</sling.java.version>
-    </properties>
-    <scm>
-        <connection>scm:svn:http://svn.apache.org/repos/asf/sling/trunk/bundles/extensions/models/impl</connection>
-        <developerConnection> scm:svn:https://svn.apache.org/repos/asf/sling/trunk/bundles/extensions/models/impl</developerConnection>
-        <url>http://svn.apache.org/viewvc/sling/trunk/bundles/extensions/models/impl</url>
-    </scm>
-    <build>
-        <plugins>
-            <plugin>
-                <groupId>org.apache.felix</groupId>
-                <artifactId>maven-scr-plugin</artifactId>
-            </plugin>
-            <plugin>
-                <groupId>org.apache.felix</groupId>
-                <artifactId>maven-bundle-plugin</artifactId>
-                <extensions>true</extensions>
-                <configuration>
-                    <instructions>
-                        <Embed-Dependency>
-                            *;scope=compile,
-                            org.osgi.compendium;inline="org/osgi/util/tracker/*"</Embed-Dependency>
-                        <!-- embed the commons.osgi bundle as described in http://njbartlett.name/2014/05/26/static-linking.html -->
-                        <Conditional-Package>org.apache.sling.commons.osgi</Conditional-Package>
-                    </instructions>
-                </configuration>
-            </plugin>
-        </plugins>
-    </build>
-    <dependencies>
-        <dependency>
-            <groupId>org.apache.sling</groupId>
-            <artifactId>org.apache.sling.models.api</artifactId>
-            <version>1.2.0</version>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>javax.servlet</groupId>
-            <artifactId>servlet-api</artifactId>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>org.osgi</groupId>
-            <artifactId>org.osgi.compendium</artifactId>
-            <version>4.2.0</version>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>org.osgi</groupId>
-            <artifactId>org.osgi.core</artifactId>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>org.apache.sling</groupId>
-            <artifactId>org.apache.sling.api</artifactId>
-            <version>2.2.0</version>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>org.slf4j</groupId>
-            <artifactId>slf4j-api</artifactId>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>org.apache.felix</groupId>
-            <artifactId>org.apache.felix.scr.annotations</artifactId>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>junit</groupId>
-            <artifactId>junit</artifactId>
-            <scope>test</scope>
-        </dependency>
-        <dependency>
-            <groupId>javax.inject</groupId>
-            <artifactId>javax.inject</artifactId>
-            <version>1</version>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>org.mockito</groupId>
-            <artifactId>mockito-all</artifactId>
-            <version>1.9.5</version>
-            <scope>test</scope>
-        </dependency>
-        <dependency>
-            <groupId>org.slf4j</groupId>
-            <artifactId>slf4j-simple</artifactId>
-            <scope>test</scope>
-        </dependency>
-        <!-- we need a pretty new version for the RankedServices, but we embed the necessary classes in this bundle -->
-        <dependency>
-            <groupId>org.apache.sling</groupId>
-            <artifactId>org.apache.sling.commons.osgi</artifactId>
-            <version>2.3.0</version>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>commons-lang</groupId>
-            <artifactId>commons-lang</artifactId>
-            <version>2.5</version>
-            <scope>provided</scope>
-        </dependency>
-        <dependency>
-            <groupId>commons-beanutils</groupId>
-            <artifactId>commons-beanutils</artifactId>
-            <version>1.8.3</version>
-            <scope>compile</scope>
-        </dependency>
-        <dependency>
-            <groupId>com.google.code.findbugs</groupId>
-            <artifactId>jsr305</artifactId>
-            <version>3.0.0</version>
-            <scope>provided</scope>
-        </dependency>
-    </dependencies>
-</project>
+<?xml version="1.0" encoding="ISO-8859-1"?>\r
+<!--\r
+  Licensed to the Apache Software Foundation (ASF) under one\r
+  or more contributor license agreements.  See the NOTICE file\r
+  distributed with this work for additional information\r
+  regarding copyright ownership.  The ASF licenses this file\r
+  to you under the Apache License, Version 2.0 (the\r
+  "License"); you may not use this file except in compliance\r
+  with the License.  You may obtain a copy of the License at\r
+\r
+   http://www.apache.org/licenses/LICENSE-2.0\r
+\r
+  Unless required by applicable law or agreed to in writing,\r
+  software distributed under the License is distributed on an\r
+  "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY\r
+  KIND, either express or implied.  See the License for the\r
+  specific language governing permissions and limitations\r
+  under the License.\r
+-->\r
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">\r
+    <modelVersion>4.0.0</modelVersion>\r
+    <parent>\r
+        <groupId>org.apache.sling</groupId>\r
+        <artifactId>sling</artifactId>\r
+        <version>22</version>\r
+        <relativePath />\r
+    </parent>\r
+    <groupId>org.apache.sling</groupId>\r
+    <artifactId>org.apache.sling.models.impl</artifactId>\r
+    <packaging>bundle</packaging>\r
+    <version>1.2.0</version>\r
+    <name>Apache Sling Models Implementation</name>\r
+    <description>Apache Sling Models Implementation</description>\r
+    <properties>\r
+        <sling.java.version>6</sling.java.version>\r
+    </properties>\r
+    <scm>\r
+        <connection>scm:svn:http://svn.apache.org/repos/asf/sling/tags/org.apache.sling.models.impl-1.2.0</connection>\r
+        <developerConnection> scm:svn:https://svn.apache.org/repos/asf/sling/tags/org.apache.sling.models.impl-1.2.0</developerConnection>\r
+        <url>http://svn.apache.org/viewvc/sling/tags/org.apache.sling.models.impl-1.2.0</url>\r
+    </scm>\r
+    <build>\r
+        <plugins>\r
+            <plugin>\r
+                <groupId>org.apache.felix</groupId>\r
+                <artifactId>maven-scr-plugin</artifactId>\r
+            </plugin>\r
+            <plugin>\r
+                <groupId>org.apache.felix</groupId>\r
+                <artifactId>maven-bundle-plugin</artifactId>\r
+                <extensions>true</extensions>\r
+                <configuration>\r
+                    <instructions>\r
+                        <Embed-Dependency>\r
+                            *;scope=compile,\r
+                            org.osgi.compendium;inline="org/osgi/util/tracker/*"</Embed-Dependency>\r
+                        <!-- embed the commons.osgi bundle as described in http://njbartlett.name/2014/05/26/static-linking.html -->\r
+                        <Conditional-Package>org.apache.sling.commons.osgi</Conditional-Package>\r
+                    </instructions>\r
+                </configuration>\r
+            </plugin>\r
+        </plugins>\r
+    </build>\r
+    <dependencies>\r
+        <dependency>\r
+            <groupId>org.apache.sling</groupId>\r
+            <artifactId>org.apache.sling.models.api</artifactId>\r
+            <version>1.2.0</version>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>javax.servlet</groupId>\r
+            <artifactId>servlet-api</artifactId>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>org.osgi</groupId>\r
+            <artifactId>org.osgi.compendium</artifactId>\r
+            <version>4.2.0</version>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>org.osgi</groupId>\r
+            <artifactId>org.osgi.core</artifactId>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>org.apache.sling</groupId>\r
+            <artifactId>org.apache.sling.api</artifactId>\r
+            <version>2.2.0</version>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>org.slf4j</groupId>\r
+            <artifactId>slf4j-api</artifactId>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>org.apache.felix</groupId>\r
+            <artifactId>org.apache.felix.scr.annotations</artifactId>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>junit</groupId>\r
+            <artifactId>junit</artifactId>\r
+            <scope>test</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>javax.inject</groupId>\r
+            <artifactId>javax.inject</artifactId>\r
+            <version>1</version>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>org.mockito</groupId>\r
+            <artifactId>mockito-all</artifactId>\r
+            <version>1.9.5</version>\r
+            <scope>test</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>org.slf4j</groupId>\r
+            <artifactId>slf4j-simple</artifactId>\r
+            <scope>test</scope>\r
+        </dependency>\r
+        <!-- we need a pretty new version for the RankedServices, but we embed the necessary classes in this bundle -->\r
+        <dependency>\r
+            <groupId>org.apache.sling</groupId>\r
+            <artifactId>org.apache.sling.commons.osgi</artifactId>\r
+            <version>2.3.0</version>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>commons-lang</groupId>\r
+            <artifactId>commons-lang</artifactId>\r
+            <version>2.5</version>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>commons-beanutils</groupId>\r
+            <artifactId>commons-beanutils</artifactId>\r
+            <version>1.8.3</version>\r
+            <scope>compile</scope>\r
+        </dependency>\r
+        <dependency>\r
+            <groupId>com.google.code.findbugs</groupId>\r
+            <artifactId>jsr305</artifactId>\r
+            <version>3.0.0</version>\r
+            <scope>provided</scope>\r
+        </dependency>\r
+    </dependencies>\r
+</project>\r