SLING-7093 - The JavaScript Use Provider should define an explicit dependency to...
authorRadu Cotescu <radu@apache.org>
Thu, 31 Aug 2017 08:54:10 +0000 (08:54 +0000)
committerRadu Cotescu <radu@apache.org>
Thu, 31 Aug 2017 08:54:10 +0000 (08:54 +0000)
* defined capabilities headers in both bundles

git-svn-id: https://svn.apache.org/repos/asf/sling/trunk@1806768 13f79535-47bb-0310-9956-ffa450edef68

pom.xml

diff --git a/pom.xml b/pom.xml
index 68baef1..e0b3be8 100644 (file)
--- a/pom.xml
+++ b/pom.xml
@@ -62,6 +62,9 @@
                         <Embed-Dependency>
                             org.apache.sling.commons.osgi;inline="org/apache/sling/commons/osgi/PropertiesUtil.*"
                         </Embed-Dependency>
+                        <Provide-Capability>
+                            osgi.implementation;osgi.implementation="org.apache.sling.scripting.javascript.rhinoscriptengine";version:Version="1.7.7.1"
+                        </Provide-Capability>
                         <_removeheaders>
                           Embed-Dependency,
                           Private-Package,